일 | 월 | 화 | 수 | 목 | 금 | 토 |
---|---|---|---|---|---|---|
1 | 2 | 3 | 4 | 5 | 6 | 7 |
8 | 9 | 10 | 11 | 12 | 13 | 14 |
15 | 16 | 17 | 18 | 19 | 20 | 21 |
22 | 23 | 24 | 25 | 26 | 27 | 28 |
29 | 30 | 31 |
- Windows
- G-suite
- x-pack
- elastic stack
- XCP-ng
- freebsd
- xe guest utilities
- proxycfg
- endpoint security
- Kibana server is not ready yet
- ELASTIC
- GitLab
- centos 8
- Elasticsearch
- 보안양파
- bash
- macos
- PlayBook
- miniconda
- docker
- hardening
- application security
- Kibana
- 한글가이드
- ssh key 배포
- Proxy
- pfsense
- ansible
- 로그인불가
- Today
- Total
선 밖에 선 자유인
suricata install in FreeBSD 본문
https://redmine.openinfosecfoundation.org/projects/suricata/wiki/FreeBSD_8
Pre-installation requirements
Before you can build Suricata for your system, run the following command to ensure that you have everything you need for the installation.
Make sure you enter all commands as root/super-user, otherwise it will not work.
pkg_add -r autoconf262 automake19 gcc45 libyaml pcre libtool \
libnet11 libpcap gmake
** pkg_add 로 설치 되지 않는 부분들이 많기 때문에 /usr/ports에서 해당 패키지들을 설치한다.
Depending on the current status of your system, it may take a while to complete this process.
HTP
HTP is bundled with Suricata and installed automatically. If you need to install HTP manually for other reasons, instructions can be found at HTP library installation.
IPS
If you would like to build suricata on FreeBSD with IPS capabilities with IPFW via --enable-ipfw, enter the following to enable ipfw and divert socket support before starting the engine with -d:
Edit /etc/rc.conf and add or modify the following lines:
firewall_enable="YES"
firewall_type="open"
Edit /boot/loader.conf and add or modify the following lines:
ipfw_load="YES"
ipfw_nat_load="YES"
ipdivert_load="YES"
dummynet_load="YES"
libalias_load="YES"
Suricata
To download and build Suricata, enter the following:
wget http://www.openinfosecfoundation.org/download/suricata-1.0.5.tar.gz
tar -xvzf suricata-1.0.5.tar.gz
cd suricata-1.0.5
If you are building from Git sources, enter all the following commands until the end of this file:
bash autogen.sh
If you are not building from Git sources, do not enter the above mentioned commands. Continue enter the following:
./configure
make
make install
zerocopy bpf
mkdir /var/log/suricata/
FreeBSD 8 has support for zerocopy bpf in libpcap. To test this functionality, issue the following command and then start/restart the engine:
sysctl net.bpf.zerocopy_enable=1